PDA

View Full Version : problems w/ Sager



premiere
09-16-2008, 12:19 PM
Heres the problemo, I've had my Sager for a little over a year now. and today while sending an email to a friend my screen froze up, and turned a weird pinkish like tint. I waited to see if it would recover but it did not. so i held the power button down so i could restart the thing and after powering back on my screen alarmed me. It seemed as though my graphics card may have defected or something im not sure so im coming here hoping i can get a solid answer hoping something may just have wiggled loose i dont know. any way the hard drive was being accessed and everything else sounded fine. but my screen would not change. i've attached a picture of what my screen was doing, btw the left side was flickering.

any input is much appreciated thanks.

Zatara214
09-16-2008, 12:32 PM
Thats never good... well as long as you can still boot, the sound works, and the hard drive is being accessed, the machine is fine. If it's a corrupted graphics card, worst case is get a replacement. I recommend getting someone on the phone to walk you through your specific model if you're gonna open it up, to try and troubleshoot. It may even be the screen itself, who knows. But yeah, call support, and see if they can walk you through checking to see that everything is in place, and if not, get a replacement part.

robamb2002
09-16-2008, 01:31 PM
I would attach a monitor to the computer to see if it is the videocard or the lcd screen. that would be my first step. and yeah, call tech support.

Sorry to hear of your troubles